Supporto Problemi con le immagini | Risolto

Blasto

Oh.
Staff Forum
Webmaster
Amministratore
Iscritto dal:
31 Marzo 2018
Messaggi
1.551
Mi Piace
40
Punteggio
48
Età
26
Codice Amico Switch
Chiedi in privato.
Codice Amico 3DS
1478-6165-2928
Steam ID
Alessandro92
#2

iSamurai

He Who Comes With the Dawn
Staff Forum
Tecnico
Iscritto dal:
31 Marzo 2018
Messaggi
592
Mi Piace
0
Punteggio
16
Età
25
Località
Treviso
Steam ID
iSamuraii
#3
Ciao, riusciresti a controllare se le immagini della tua firma sono effettivamente raggiungibili? Controllando con Is postimg.org down? sembrerebbe un problema del servizio di hosting immagini, riesci a caricare quelle immagini su un sito diverso (ad esempio imgur) e vedere se si riscontra ancora il problema?
 

Manuel89

Member
Utente
Iscritto dal:
3 Aprile 2018
Messaggi
113
Mi Piace
0
Punteggio
16
Località
Roma
#4
Ciao, riusciresti a controllare se le immagini della tua firma sono effettivamente raggiungibili? Controllando con Is postimg.org down? sembrerebbe un problema del servizio di hosting immagini, riesci a caricare quelle immagini su un sito diverso (ad esempio imgur) e vedere se si riscontra ancora il problema?
Con imgur nemmeno me le carica in fase di modifica. Al contrario delle "originali". E' normale che in altri forum non abbia problemi con le stesse immagini?
 

iSamurai

He Who Comes With the Dawn
Staff Forum
Tecnico
Iscritto dal:
31 Marzo 2018
Messaggi
592
Mi Piace
0
Punteggio
16
Età
25
Località
Treviso
Steam ID
iSamuraii
#5
Riusciresti a lasciarmi un link alle immagini? Questo pomeriggio ho provato a impostare un proxy delle immagini attraverso il nostro server (per questioni di performance e di sicurezza), potrebbe essere un problema di dimensioni del file ma mi sembra strano lo stesso.
 

Manuel89

Member
Utente
Iscritto dal:
3 Aprile 2018
Messaggi
113
Mi Piace
0
Punteggio
16
Località
Roma
#6

iSamurai

He Who Comes With the Dawn
Staff Forum
Tecnico
Iscritto dal:
31 Marzo 2018
Messaggi
592
Mi Piace
0
Punteggio
16
Età
25
Località
Treviso
Steam ID
iSamuraii
#7
La gif è davvero strano, da quel link non riesco a visualizzarla, ho controllato per sicurezza da un paio di servizi di ping remoti e non va in ogni caso, sei sicuro che il link sia corretto e di riuscire a vederla (attenzione che non sia una copia cache nel tuo browser, l'ideale sarebbe provare con un browser in modalità incognito)?

Per quanto riguarda l'altra immagine, è più interessante il discorso, dall'estensione sembrerebbe un immagine png, ma è animata (cosa impossibile dato che il png non è animato) come mai? Andando a vedere il mime type (e verificando dopo il DOM in pagina direttamente) in realtà non è un png bensì un svg (ignoro il motivo per cui è esposta con un'estensione diversa, probabilmente per forzare la visualizzazione su vecchie versioni di IE) che sfrutta più elementi interni per creare l'animazione, gli sviluppatori di xenforo hanno deciso di impedire il proxy di file svg per ragioni di sicurezza che condivido (dentro ad un svg si potrebbero inserire anche dei file javascript giusto per fare un esempio, si potrebbe fare un attacco XSS quindi), dato che la modifica alla gestione delle immagini è stata fatta sì per una questione di performance ma soprattutto per una questione di sicurezza mi dispiace dirti che il non funzionamento è corretto.
 

Manuel89

Member
Utente
Iscritto dal:
3 Aprile 2018
Messaggi
113
Mi Piace
0
Punteggio
16
Località
Roma
#8
La gif è davvero strano, da quel link non riesco a visualizzarla, ho controllato per sicurezza da un paio di servizi di ping remoti e non va in ogni caso, sei sicuro che il link sia corretto e di riuscire a vederla (attenzione che non sia una copia cache nel tuo browser, l'ideale sarebbe provare con un browser in modalità incognito)?

Per quanto riguarda l'altra immagine, è più interessante il discorso, dall'estensione sembrerebbe un immagine png, ma è animata (cosa impossibile dato che il png non è animato) come mai? Andando a vedere il mime type (e verificando dopo il DOM in pagina direttamente) in realtà non è un png bensì un svg (ignoro il motivo per cui è esposta con un'estensione diversa, probabilmente per forzare la visualizzazione su vecchie versioni di IE) che sfrutta più elementi interni per creare l'animazione, gli sviluppatori di xenforo hanno deciso di impedire il proxy di file svg per ragioni di sicurezza che condivido (dentro ad un svg si potrebbero inserire anche dei file javascript giusto per fare un esempio, si potrebbe fare un attacco XSS quindi), dato che la modifica alla gestione delle immagini è stata fatta sì per una questione di performance ma soprattutto per una questione di sicurezza mi dispiace dirti che il non funzionamento è corretto.
Ho capito. Tra le altre, la gif non funge più nemmeno in altri forum ora. Vedrò se riesco a rimediare con un altro sito!
 

iSamurai

He Who Comes With the Dawn
Staff Forum
Tecnico
Iscritto dal:
31 Marzo 2018
Messaggi
592
Mi Piace
0
Punteggio
16
Età
25
Località
Treviso
Steam ID
iSamuraii
#9
A quanto sembra postimage ha dovuto cambiare dominio da .org a .cc l'11 aprile, se ti andava la GIF era perché l'avevi ancora in cache nel tuo browser, dovrebbe bastare un cambio nel link da .org a .cc per farla andare.
 
Top